Raspberri Pi-talvez mais uma opção para 'weather server'?

jcboliveira

Cirrus
Registo
28 Nov 2014
Mensagens
91
Local
Porto
sim

O weewx e o vproweather são pelo menos duas opções que eu conheça.
Wview:
Simples de instalar com raspbian;
Configuração por interface web;
mais pesado em termos de funcionamento;

weewx
Instalação implica andar a alterar ficheiros de configuração;
Escrito numa linguagem mais moderna;
Desenvolvimento mais ativo por parte do autor;
Gráficos mais bonitos;

vproweather
Muito leve
Tem que ser compilado;
Tem que levar uma série de "programas cola" para funcionar com páginas web;
Não suporta wunderground;

Weatherdisplay
Pago;
suporte decente;
 
Última edição:

ijv

Cumulus
Registo
28 Nov 2010
Mensagens
481
Local
Funchal-Santo António (Altitude-808m)
Eu comprei a rpi2 já andei a testar com o cumulusMX. Até ao momento tem, funcionado muito bem, só que ainda estou com algumas dúvidas. Ao enviar um ficheiro php com as variáveis, ele parece não enviar todo os dados no ficheiro.
Ando a testar para ver se consigo colocar a estação a funcionar apena com o rpi2 e desligar o pc
 
  • Gosto
Reactions: CptRena

ijv

Cumulus
Registo
28 Nov 2010
Mensagens
481
Local
Funchal-Santo António (Altitude-808m)
Tenta pesquisar no fórum da Sandaysoft e mantendo atenção ao tópico dos anúncios, provavelmente algum bug.
SpiderVV tenho andado sempre a acompanhar o forum do sandaysfot. Vou aguardar a ver se sai alguma atualização
 
  • Gosto
Reactions: SpiderVV

Joao Silva

Cirrus
Registo
12 Out 2011
Mensagens
19
Local
Lourinhã
sim

O weewx e o vproweather são pelo menos duas opções que eu conheça.
Wview:
Simples de instalar com raspbian;
Configuração por interface web;
mais pesado em termos de funcionamento;

weewx
Instalação implica andar a alterar ficheiros de configuração;
Escrito numa linguagem mais moderna;
Desenvolvimento mais ativo por parte do autor;
Gráficos mais bonitos;

vproweather
Muito leve
Tem que ser compilado;
Tem que levar uma série de "programas cola" para funcionar com páginas web;
Não suporta wunderground;

Weatherdisplay
Pago;
suporte decente;


Boas,

Tenho o weewx a funcionar à pouco mais de 1 semana num raspberry py ligado a uma PCE-FWS 20 e tem-se portado bem até ao momento! Porém, tenho uma questão que talvez alguém me possa ajudar: preciso de corrigir um offset de 2 hPa da minha estação e coloco "barometer = barometer + 2000" (Pa) naturalmente descomentado nas configurações do weewx e reinicio, mas não surge qualquer alteração nos dados online no weather underground! Algum de vós me saberá dizer o que não estou a fazer bem?!

http://www.wunderground.com/personal-weather-station/dashboard?ID=ILISBOAM2#history
 

CptRena

Nimbostratus
Registo
16 Fev 2011
Mensagens
1,510
Local
Gafanha da Encarnação, Aveiro
Boa tarde

Ontem, eu e o @Estação SP, passámos a tarde toda, e continou-se pela noite dentro, de volta de um raspberry.
Foi a primeira vez que contactei com um rasp, mas tenho bons conhecimentos de Linux, e por isso não achei nada complicado. Estava bastante à vontade com os procedimentos.
Mas, após tanto tempo a queimar neurónios, não conseguimos que ficasse operacional.
Eu suspeito de defeito no rasp, mas gostaria de ouvir as opiniões de pessoal já calejado em raspberry.

Raspberry Pi Modelo B+ de 2014

Procedimento efectuado:
» Gravei a imagem do raspbian mais recente (2015-05-05-raspbian-wheezy.img) no microSD
» Coloquei o SD no rasp e conectei um teclado e um rato, nas portas USB, para configurar o SO.
» Ligou-se o rasp à fonte (2A) e tudo correu bem
» Durante o primeiro processo de configuração, e após várias gaffes a configurar o layout do teclado, fez-se uma nova gravação do raspbian para o SD
» Desta vez configurou-se tudo certinho e bonitinho, e já estava tudo pronto para deixar o rasp junto da consola PCE, para depois eu, em casa, através de SSH, fazer o resto da configuração
» Pois bem, desligou-se o rasp e fomos ligá-lo então junto da zona da consola
» E o rasp pôs-se a "crashar"
» Após vários testes reparou-se que aquele rasp só funciona minimamente bem quando tem o teclado e o rato ligados. Mas supostamente o raspberry deveria funcionar completamente "headless"; sem monitores, nem periféricos, não é?

Os crashes são de dois tipos:
* Começa o boot e depois fica com os dois leds ligados e a saída de video (jack 3.5mm) a preto (sem sinal na TV)
* Começa o boot, pára e volta ao início, infinitamente.

Alguém tem alguma ideia, para além de o rasp estar defeituoso, para este problema?


Cumprimentos
 

Werk_AG

Cumulus
Registo
12 Jan 2013
Mensagens
279
Local
Cercal CDV
Boa tarde


* Começa o boot e depois fica com os dois leds ligados e a saída de video (jack 3.5mm) a preto (sem sinal na TV)

Apenas uma nota:
O jack the 3.5 mm é uma saída de Audio e não de sinal video.
A ligação video faz-se pela ficha HDMI
 

CptRena

Nimbostratus
Registo
16 Fev 2011
Mensagens
1,510
Local
Gafanha da Encarnação, Aveiro
Apenas uma nota:
O jack the 3.5 mm é uma saída de Audio e não de sinal video.
A ligação video faz-se pela ficha HDMI


Olhe que não.

"Composite Port

For analogue TVs you can use a standard RCA composite video lead. The B+ and Pi 2 Model B do not have the large composite port, but can still be used with an analogue TV by plugging in to the 3.5mm socket that is also used for audio: you'll need a 3.5mm composite video/audio lead." in https://www.raspberrypi.org/documentation/setup/monitor-connection.md

E também aqui: http://www.raspberrypi-spy.co.uk/2014/07/raspberry-pi-model-b-3-5mm-audiovideo-jack/
 

Werk_AG

Cumulus
Registo
12 Jan 2013
Mensagens
279
Local
Cercal CDV
Obrigado pelo esclarecimento. Extranha opção essa, mas parece que é assim mesmo!
Veja lá, que tenho dois PI B+ e nunca tinha dado conta disso. Uso o jack 3.5 mm apenas para sáida de audio.
 

CptRena

Nimbostratus
Registo
16 Fev 2011
Mensagens
1,510
Local
Gafanha da Encarnação, Aveiro